Transformando Horas, minutos e segundos em valores numéricos (decimais)

Olá pessoal, a resposta de hoje é sobre conversões de horas em valores numéricos decimais. Aproveitem.
Pergunta formulada:

Olá… Gostaria de uma ajuda, pois já fiz de tudo, já pesquisei em tudo que é lugar e não consigo tranformar um resultado que esta em hh:mm:ss em número. Estou calculando horas, minutos e segundos. Então o resultado final dá por ex: 00:04:05. Eu queria transformar isso em segundos que seria 245 certo… mas não estou conseguindo por favor me ajude…

Resposta Excel do Seu Jeito:
Muita calma nessa hora! A solução para esta questão não é nenhum bicho de sete cabeças!
Infelizmente (ou felizmente) para muita gente a resposta que vou apresentar causaria arrepios só em falar que recorreremos a matemática para fazermos os devidos e necessários cálculos de conversão. Mas eu garanto: Não é preciso correr para comprar analgésicos para dores de cabeça, não. É tudo muito simples. Simples mesmo.
Então vamos a solução.Primeiro, um pouco de teoria.
Sabemos que 1 minuto é composto de 60 segundos. E que, 1 hora, por sua vez, e formada por 60 minutos, ou, em segundos, 60 minutos vezes 60 segundos, que representa 3600 segundos. Veja a tabela.

Valor Equivale a
1 Minuto 60 Segundos
1 Hora 60 Minutos
1 Hora 60 minutos x 60 segundos = 3600 segundos
1 Minuto x segundos / 60
1 Hora x minutos / 60
1 Hora x segundos / 3600



Com essa tabela podemos ilustrar os cálculos básicos que precisamos fazer nas fórmulas para que consigam retornar para nós os valores de hora em números decimais. Não vou explicar aqui os conceitos matemáticos, mas, o que precisamos saber é que 1 hora, 60 minutos ou 3600 segundos são a mesma coisa.
Exemplo: 1 hora e 30 minutos (1,5). Costuma se dizer “uma e meia“.


1 (hora) x 60 (minutos) + 30 (minutos) = 90 (Aqui a conversão foi para minutos)
1 (hora) x 3600 (segundos) + 30 (minutos) x 60 (segundos) = 5400 (Aqui a conversão foi para segundos)
1 (hora) + 30 (minutos) / 60 (minutos) = 1,5 (Aqui a conversão foi para hora)


Jogando isto em fórmulas do excel, teremos: (Supondo que a hora digitada esteja na célula A1)


Para converter em segundos


=SOMA(HORA(A1)*3600;MINUTO(A1)*60;SEGUNDO(A1))


Para converter em minutos


=SOMA(HORA(A1)*60;MINUTO(A1);SEGUNDO(A1)/60)


Para converter em horas


=SOMA(HORA(A1);MINUTO(A1)/60;SEGUNDO(A1)/3600)


Então é isso galera.


Até a próxima.

Tags: No tags

Leave a Comment