Olá pessoas EXCELentes!!!

O artigo de hoje é o último desta série que publiquei sobre as mensagens de erros retornadas pelas fórmulas do Excel. Agora falaremos sobre a mensagem de erro #NULO!.

Veja todos as dicas desta série:

Parte 1 – Erro #N/D
Parte 2 – Erro #VALOR!
Parte 3 – Erro #REF!
Parte 4 – Erro #DIV/0!
Parte 5 – Erro #NÚM!
Parte 6 – Erro #NOME?
Parte 7 – Erro #NULO! (Aprenderemos agora! Ufa!! Este é o último.)

 

O que significa #NULO!

O tipo de erro #NULO! é menos comum de ocorrer e é exibido quando uma referência a dois intervalos de uma intercessão não são interceptados  de fato. O operador de interseção é um caractere de espaço entre referências.

Embora não seja tão aplicado este tipo de construção, vamos entendê-la através do exemplo a seguir.

Tomemos como base a tabela desta figura.

Um exemplo de intercessão de intervalos, seria dado assim:

= SOMA(B1:B10 A4:C6) // Resultado: 44, ou seja, 10+15+19, correspondente a intercessão B4 a B6.

Veja na figura abaixo e entenda melhor.

Os intervalos se cruzam justamente nas células B4, B5 e B6.

Um erro ocorreria se estes intervalos não se interceptassem, veja:

= SOMA(B1:B10 C2:C6) // Resultado: #NULO!

 

Como solucionar?

 

Podemos corrigir esse problema efetuando pequenas alterações na fórmula.

  • Corrija um ou mais intervalos, de modo que, exista uma intercessão entre as referências informadas. Lembrando que uma intercessão são as células em comum a dois intervalos.
     
  • Outra maneira de resolver seria redefinir os intervalos utilizando o ponto-e-vírgula (;) para distinguir os intervalos.

    Ex: = SOMA(B1:B10;C2:C6)

 

Com estas ações, você poderá corrigir possíveis erros na digitação de suas fórmulas. Se o caso, não for passível de correção, ou seja, um erro seja esperado ou previsto no retorno de sua fórmula, mas, você quer tratar este erro para que sua planilha fique mais elegante, sem exibir #NULO! nas células, leia este artigo aqui.

 

Espero que tenham gostado.

Não deixem de comentar e compartilhar com seus amigos pelo twitter, facebook, Google+, ok!

 

Um Abraço.