Olá pessoas EXCELentes!!!

Dando continuidade a série de dicas sobre correção de erros, agora falaremos sobre a mensagem de erro #DIV/0!.

Veja todos as dicas desta série:

Parte 1 – Erro #N/D
Parte 2 – Erro #VALOR!
Parte 3 – Erro #REF!
Parte 4 – Erro #DIV/0! (Aprenderemos agora!)
Parte 5 – Erro #NÚM!
Parte 6 – Erro #NOME?
Parte 7 – Erro #NULO!

 

O que significa #DIV/0?

O tipo de erro #DIV/0! é o mais fácil e óbvio possível, pois, trata-se de matemática pura. Alguém aqui tem problemas com matemática? Espero que não!!! :-)

#DIV/0 significa que um número está sendo dividido por 0 (zero) ou por uma célula que não contenha um valor válido.

Contra um fundamento tão real não podemos contestar. Diante disso, os exemplos são bem simples, veja:

Uma fórmula simples que resultaria neste erro seria assim:

= A1 / B1  Onde A1 = 10 e B1 = 0. // Resultado: #DIV/0!

=QUOCIENTE(A1;B1)      // Resultado: #DIV/0!

 

Sem mais delongas, vejamos como corrigir.


 

Como solucionar?

 

Podemos corrigir esse problema efetuando pequenas alterações na fórmula.

  • Primeiramente, tente identificar se sua fórmula está dividindo diretamente por zero, ou faz referência a uma célula que possua valor 0 ou seja vazia. Ou ainda, se faz divisão por um resultado de outra fórmula que retorne 0.
  • Outras maneiras de resolver, estão explicadas neste artigo aqui. Um destas formas seria, condicionar o cálculo apenas se o divisor não fosse zero. Ex: =SE(A2=0;0;A1/A2)

 

Com estas ações, você poderá corrigir possíveis erros na digitação de suas fórmulas. Se o caso, não for passível de correção, ou seja, um erro seja esperado ou previsto no retorno de sua fórmula, mas, você quer tratar este erro para que sua planilha fique mais elegante, sem exibir #DIV/0! nas células, leia este artigo aqui.

 

Espero que gostem. Na próxima dica ensino como corrigir o erro #NÚM!.

 

Se gostarem, comentem e compartilhem com seus amigos pelo twitter, facebook, Google+, ok!

 

Um Abraço.