Olá pessoas EXCELentes!!!

Dando continuidade a série de dicas sobre correção de erros, agora falaremos sobre a mensagem de erro #VALOR!.

Veja todos as dicas desta série:

Parte 1 – Erro #N/D
Parte 2 – Erro #VALOR!  (Aprenderemos agora!)
Parte 3 – Erro #REF!
Parte 4 – Erro #DIV/0!
Parte 5 – Erro #NÚM!
Parte 6 – Erro #NOME?
Parte 7 – Erro #NULO!

 

O que significa #VALOR!

O tipo de erro #VALOR! significa que foram encontrados tipos diferentes de dados em sua fórmula, ou seja, uma mistura de dados numéricos com valores textuais, por exemplo.

Se ocorresse isso em uma fórmula matemática teríamos um erro.

Um exemplo de quando seria gerado o erro #VALOR! poderia ser descrito numa fórmula simples do tipo:

= A1 + B1        // Resultado: #VALOR!

Onde A1 = 10 e B1 = “carros”.

Numa concatenação, por exemplo, não encontraríamos problema algum, pois, ficaria assim:

=CONCATENAR(A1, “ ”, B1)    // Resultado: 10 carros

O erro se dá porque B1 corresponde a um valor de texto e não, a um valor numérico que pudesse ser calculado com A1. Isso vai ocorrer com qualquer cálculo matemático, utilizando os operadores aritméticos ou as funções como SOMA, PRODUTO e outras.

 

Como solucionar?

 

Podemos corrigir esse problema efetuando pequenas alterações na fórmula.

  • Em vez de utilizar operadores aritméticos (+ – * /), utilize uma função, como SOMA, PRODUTO ou QUOCIENTE para executar uma operação aritmética nas células que podem conter texto e evite o uso de operadores aritméticos na função. Em vez disso, separe os argumentos utilizando (;) ponto-vírgula.

    Por exemplo:

    É melhor utilizar a fórmula:

    =SOMA(A1;B1;C1)

    Em vez de:

    =A1+B1+C1 ou =SOMA(A1+B1+C1) 

  • Assegure-se de que nenhum dos argumentos de uma função matemática, como SOMA, PRODUTO ou QUOCIENTE, contenha texto como um argumento diretamente na função.

    Ex: =PRODUTO(A1;”carros”)

  • Se a fórmula utilizar uma função e essa função se referir a uma célula que contém texto, essa célula será ignorada e nenhum erro será exibido.

 

Com estas ações, você poderá corrigir possíveis erros na digitação de suas fórmulas. Se o caso, não for passível de correção, ou seja, um erro seja esperado ou previsto no retorno de sua fórmula, mas, você quer tratar este erro para que sua planilha fique mais elegante, sem exibir #VALOR! nas células, leia este artigo aqui.

 

Espero que gostem. Na próxima dica ensino como corrigir o erro #REF!.

 

Se gostarem, comentem e compartilhem com seus amigos pelo twitter, facebook, Google+, ok!

 

Um Abraço.