Olá amigos

Hoje vou postar um exemplo prático que desenvolvi atendendo uma dúvida postada por um leitor deste blog.

A necessidade era para que ao digitar um sigla de determinado Estado brasileiro, fosse exibido em um outra célula, o nome por extenso desse mesmo Estado.

Vou aproveitar essa questão para ensinar a vocês um pouco mais sobre fórmulas para pesquisa e referência numa planilha Excel. Neste caso aqui, poderíamos recorrer a função PROCV, que é super conhecida por muitos, embora, a maioria tenha dificuldade em utilizá-la. Mas, gostaria de apresentar-lhes algo mais alternativo, para que vocês possam especializar-se ainda mais, meus amigos.

Para isso, userei uma combinação de duas fórmulas e criarei uma lista com os Estados e suas Siglas, no caso deste exemplo ainda adicionarei uma coluna Capitais.

A listagem deve ficar como esta:

Abreviação Estado Capital
AC Acre Rio Branco
AL Alagoas Maceió
AM Amazonas Manaus
AP Amapá Macapá
BA Bahia Salvador
CE Ceará Fortaleza
DF Distrito Federal Brasília
ES Espírito Santo Vitória
GO Goiás Goiânia
MA Maranhão São Luís
MG Minas Gerais Belo Horizonte
MS Mato Grosso do Sul Campo Grande
MT Mato Grosso Cuiabá
PA Pará Belém
PB Paraíba João Pessoa
PE Pernambuco Recife
PI Piauí Teresina
PR Paraná Curitiba
RJ Rio de Janeiro Rio de Janeiro
RN Rio Grande do Norte Natal
RO Rondônia Porto Velho
RR Roraima Boa Vista
RS Rio Grande do Sul Porto Alegre
SC Santa Catarina Florianópolis
SE Sergipe Aracaju
SP São Paulo São Paulo
TO Tocantins Palmas

Como aplicar a fórmula

Antes de iniciarmos pra valer, é interessante que você leia também o artigo sobre PROCV. Este artigo faz parte do meu eBook 7 Fórmulas do Excel Que Podem Salvar Sua Vida que ensina o uso das fórmulas mais essenciais e úteis do Excel. Veja aqui.

Para prosseguirmos bem o nosso estudo, crie esta lista acima na Plan2. Esta planilha poderá ficar oculta. Não há necessidade de ser visualizada, será utilizada apenas como referência para a fórmula.

Agora suponha que você queira digitar a sigla do estado na célula B3 e exibir o nome do estado em D3 e a capital em E3.

Digite em D3, a seguinte fórmula:

=ÍNDICE(Plan2!A1:C28;CORRESP(B3;Plan2!A1:A28;0);2)

Digite em E3, a seguinte fórmula:

=ÍNDICE(Plan2!A1:C28;CORRESP(B3;Plan2!A1:A28;0);3)

 

A função CORRESP procura pela sigla digitada em B3 na tabelinha existente no intervalo A1:A28 da Plan2 e retorna a posição vertical onde o valor foi encontrado, em nosso caso, corresponde o número exato da linha no excel. E a função ÍNDICE exibe o valor cruzado entre a linha informada (obtida pelo CORRESP anteriormente) e a coluna onde possui os dados que você deseja, no caso do nome do estado, coluna 2, no caso da capital, coluna 3.

Bem simples né.

Disponibilizei o arquivo usado nesta matéria para vocês baixarem, ok. O link para download está no final do artigo.

Um abraço.

 

Antes de efetuar o download do arquivo de exemplo, convido você a socializar conosco.

Escolha uma das opções abaixo. Seguir no twitter, assinar nossa Newsletter...

Isso nos ajuda na divulgação do site e te permite ficar sempre atualizado das novidades. Fico muito grato pela sua colaboração.

Digite seu email:

Você receberá um email para ativar o cadastro, ok!