Amigos, hoje vamos executar algo extremamente simples mas que muitas vezes já nos deu muita dor de cabeça.

Suponha que tenhamos uma gigantesca listagem, por exemplo, uma lista telefônica. E nela não podemos exibir telefones repetidos, precisamos que esses números figurem apenas uma única vez na nossa lista. Se formos procurar linha por linha, poderemos terminar ficando vesgos de tanto fixar o olhar em buscas dos números repetidos, sem contar que nosso cérebro ficaria atordoado com tantos números e sem dúvida não conseguiria decorar se o número que estava lendo já haveria aparecido alguma vez.

Uma solução simples, e para fins de estudo, seria assim: Aplicaríamos a Formatação Condicional na coluna Telefones, instruíndo-a para alterar a cor de fundo da célula em que fosse encontrado um número de telefone repetido. Visualmente, ficaria, então, muito mais fácil identificar essas linhas repetidas e assim, excluí-las.

Como fazer:

  1. Selecione toda a coluna que contém os números de telefone (Suponha que seja toda a coluna A).
  2. Clique na opção “Formatação Condicional…” do menu “Formatar”.
  3. No campo onde está escrito “O valor da célula é” substitua para “A Fórmula é“.
  4. No campo ao lado digite a fórmula: “=CONT.SE(A:A;A1)>1“.
  5. Clique no botão “Formatar…”
  6. Na janela que se abre, selecione a aba “Padrões“, excolha uma cor qualquer e dê OK.
  7. Dê OK novamente e pronto.

Agora todas as células com números repetidos estarão sombreadas com a cor escolhida.

Um abraço a todos.

Termos apredidos neste artigo:

CONT.SE Calcula o número de células não vazias em um intervalo que corresponde a
determinados critérios.

Sintaxe

CONT.SE(intervalo;critérios)

Intervalo é o intervalo de células no qual se deseja contar células não
vazias.

Critérios é o critério na forma de um número, expressão ou texto que
define quais células serão contadas. Por exemplo, os critérios podem ser
expressos como 32, “32”, “>32″, “maçãs”.